Partial Connectivity Issues in Astra Serverless AWS us-west-2

Incident Report for DataStax Astra

Resolved

This incident has been fully resolved.
Posted Feb 25, 2026 - 06:05 UTC

Monitoring

Connectivity issues in the AWS us-west-2 region has stabilized, and error rates have returned to normal levels. We are continuing to monitor the situation closely to ensure full stability.
Posted Feb 25, 2026 - 05:54 UTC

Investigating

We are currently investigating partial connectivity issues affecting Astra Serverless in the AWS us-west-2 region.
Posted Feb 25, 2026 - 05:38 UTC
This incident affected: Astra (Astra Serverless DB).